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SPM Tip - Easy Phantograms

1. Take a picture of an object on a sheet of

8X10 paper from a 45 degree angle and

open it in SPM.

2. Select Adjust/Auto detect Rectangle or

press [Alt+G] key.

3. After detecting the background 8X10 paper, the 'Easy Create

Popup Anaglyph' Edit screen will be displayed:

4. Select the [rectangle]

button and input your

8X10 aspect ratio.

The image will align the

corners of the rectangle

and apply the aspect

ratio. Press “OK”.

by Dennis Green
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SPM Quick Tip - EZ Stereo Cards
by Dennis Green

Stereo cards are the classic way to view 3D images. They make

wonderful gifts, either as a single card or as a set to display an

event like a wedding or family gathering.  Here are the steps to do

this easily in StereoPhoto Maker:

1) Select and crop an image.

Start with an adjusted pair (see the SPM Tip on auto-

alignment).  Under the Crop tool’s free cropping options, there are

buttons for the various card types with different aspect ratios.

You can try them out

to see which you like

best. For this ex-

ample, we will use

the “Classic Stereo

Card” option.

Now use the Crop

tool to select the amount of the image you want in your card.

5

5. Using the Stereo options, display as side-by-side.

6. Crop the image to the edges of the background sheet.

7. Change to anaglyph viewing mode and save the image,

checking the 'No compression ghosting' option. Be sure the

“Always save SBS format” box is unchecked.  You want to save

this as an anaglyph to be able to print it.  That’s it!  [    ][    ]
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Text in the “Title” field prints on the ends of the card.  The “Author”

field prints under the image, where the image title would normally

be found.  You can change the font using the font button, and the

text size by changing the number in the box.

Try some different text colors and background colors until you get

a combination that you like. Then click on the “Arch” box to get the

rounded top.  The RoundRect box will round the corners of the

bottom of the image if you have “Arch” selected, or of all four

corners if “Arch” is not selected.

Now click the “Show Card” button to see a mono image of what

the card will look like:

If you want to change something, just press the “Z” key to undo the

“Show Card” action and select “File... Print Stereo Card” again. All

of your settings will still be there, so just change the ones you want

to modify, and press “Show Card” again to see the modifications.

When you are happy with the card, choose “Save as...”  to create a

file that you can take to Costco or CVS to have printed, or you can

press the “Print” button to use your own printer.  You can then paste

the finished print on some matte board and trim it to size to give it

a more authentic feel.    [    ][    ]

7

Now select “File... Print Stereo Card”, which will give you this

dialog box where you make your choices for the colors and text:

At the top is the selection for the size card you want. The classic

card is 7 X 3.5 inches.  The “Holmes” selection is for a 4 X 6 inch

print, which is convenient to print at the drug store. The box next to

that top box is how far the image is from the top of the card.  If you

want a title under the image like the Keystone or U&U cards, you

may have to reduce that distance to give space at the bottom.

Click on the “Canvas Size” button at

the bottom and change the size to “7”

in the “X” field and “4” in the “Y” field.

This is the “APS-C Print” size, which

many drug store printers will print for

the same cost as the cheaper 4 X 6

size, yet it allows a full size card

background.
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If the color balance or the exposure of the left and right images are

not the same, you would first use the Auto Color Adjustment to fix

this before proceeding.  Otherwise your edits will be obvious, as

they will not blend in.

To align the depth,

just press the “K”

key which is the

shortcut for “Easy

Alignment”. Press

the “100%” button

and drag the image

to the area you want

to align. Use the

horizontal arrows at

the top to move the

red and cyan versions

 on top of each other (in this case, I used the stair railing).

Once the layers are aligned, switch back to side-by-side view.

SPM always clones from the image on the left to the image on the

right, so if you want to change the Left eye image, use the “X” key

to swap sides and put it on the right side while you modify it.

To start cloning, place your cursor in the area to be affected, and

press the Shift key and left mouse button at the same time.  The

cursor will change to the clone tool.  You can change the size or

shape of the tool by pressing [Ctrl-N] (or select “Clone Brush

Setting” from the Edit menu).  The choices are a thin horizontal,

vertical or diagonal rectangle, or a circle.  Changing the size will

vary the length of the rectangle or the diameter of the circle.  After

cloning the people, realigning and saving it, here is my image:

Before move After move

SPM Tip: Clone Tool - Part 2
by Dennis Green

In the January 2016 newsletter, we showed one use of the SPM

Clone Tool - to clone out a finger blocking part of one image. In

this tip we will show two more uses of this handy tool - repairing

something that moved, and moving image elements.

1. Repairing objects (or people) that have moved during a
cha-cha image.

Cha-cha shots can be used to do a hyper or close-up image using

the advanced 3D program on the Fuji W3, or to capture a stereo

image with a phone camera when you do not have a 3D camera

with you.  Often image elements will have moved in between

taking the left and right images.  For example, this image was

taken with an extended (hyper) stereo base using my W3 this

summer at Blarney Castle, in Ireland.

As you can see, there are many people who moved in the picture,

which causes a lot of discrepancies between the left and right

images, and does not look good.

To fix this, I just opened the image in SPM and decided which

elements I wanted to keep and transfer to the other side.  I started

with some of the people at the bottom of the stairs, and adjusted

the stereo pair so that the desired group and their immediate

background were aligned, which meant that anything cloned from

one side would appear at the same depth as the original.  If I

didn’t do that, those people would appear “at the window” in the

final image instead of back where the stairs are.



       SPM Quick Tips    2018   |     |     SPM Quick Tips 201810 11

SPM Quick Tip: Google Camera Fun
by Dennis Green

StereoPhoto Maker has a function that can take advantage of an

image captured with the Google Camera app using the “lens blur”

option. This phone camera option is intended to allow you to

create an image with the subject sharp, and the background

blurred. This is done due to the app creating a depth map when

the image is taken (you must move the camera vertically while

taking the picture to create the depth map).  SPM uses that depth

map to create three different types of images:

1. A stereo pair

2. A multi-image view for making animated GIF images.

3. A lens blur image, which then can be converted to stereo.

Since you must move the camera while taking the image, you may

wonder why not just take a pair of images?  The lens blur image

offers a few advantages:

1. When you create your stereo pair, you can adjust the depth of

the final image, viewing it on screen to get the desired amount.

2. You can create your multi-image group with a variable number

of images between your left and right image to make a smooth

wiggle view instead of the more common jerky versions.

3. You can select your point of focus for the blurred lens image

after taking the shot, getting multiple different images from the

same original.

To create a 3D pair from the image, the first step is to open both

the image and depth map in SPM.  This is done by using the

Depth Map option from the Edit menu.

2. Moving an image element.

Sometimes an image element causes either a window violation or

excess deviation, making the image difficult or impossible to view.

This can be corrected using the clone tool to change the depth

location of that element.  Here is an image of performers in a

church, where the pew in front of me is much too close, causing

both a window violation and excessive depth.

By using the clone tool and moving the pew in the right image

farther to the right, it moves the depth location farther back. After

moving the pew, the parts of the image that were blocked by the

pew need to be cloned in at their proper depth.  Fortunately, there
were only a couple of depth layers that had to be cloned.  The end

of the piano and the accordion on the floor were at about the same

depth, and the far background was at another.  By aligning the

piano first and cloning in it and the accordion, then changing the

depth by aligning the vertical flag stand in the back and cloning the

other background elements, I was able to save the image and

make it viewable.  Here is the image with the pew moved back:

A step-by-step instruction is on our web “How to...” page.     [    ][    ]
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Now you can continue with the other options of making a lens blur

image or a multi-image set for making a lenticular print or an

animation GIF (wiggle stereo) image.

If you would like to experiment with this creative tool, just download

the “Google Camera” app (free) and select the “lens blur” option

when you take the image.

This app and the SPM tool are not meant to be replacements for a

stereo camera or even a cha-cha (single camera stereo) image,

but they are extra tools for your stereographic toolbox.      [    ][    ]

The final saved stereo image.  Multiple versions can be saved with different depths.

13

The image and its depth map will open in SPM.

For the second step, use the option [Edit->Depth map->Create

3D image from 2D+Depth map] or [Alt+D]. This will bring up a

dialog box with the initial deviation amount.  A value of 30 is the

default and will usually give you a good image.  SPM will now

generate a side-by-side stereo pair.

The third step is to view the image onscreen and try different

deviation amounts by using [Ctrl+Page Up(Down)].  You can

change the viewing method, just as you would with any stereo

image.  Increase and decrease the depth until you have an image

that is neither too shallow (with little stereo depth) or too deep (to

cause a viewer some eye strain to view the image).

The last step is to save the image.
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3. View tab settings.  Under the “view” tab, you can set your

background color to

black, white, or any

other color to make

viewing easiest. The

border can be set to

increase the distance

around the image to

make it easier to view

or to maximum size.

The distance between the images can be changed using the “e”

key as a toggle between three choices:

Narrow is best for parallel

free-viewing images, as it

allows the window to be

larger without making the

images too far apart.

Medium is best for cross-

eye free viewing or using a

screen viewer. This centers

the images in the available

window.

Wide is best for viewing in

mirror-mode using a small

hand mirror (see “Mirror

View Method for Stereo

Images” in SPM Quick Tips

Volume I found in the How-

To area of our website).

Hopefully one or more of these settings will make SPM a little more

enjoyable to use.        [    ][    ]

SPM Quick Tip: Three Settings

This month’s Quick Tip centers on some settings that you can

check or uncheck in the Preferences area to make your use of

StereoPhoto Maker more to your liking.

1. Startup with its window maximized.  When you open SPM,

either by double-clicking on the program or on an MPO file, the

program comes up in a small window, which you have to maximize

in order to have it fill the

screen.  There is a checkbox

that gives the option of having

SPM open maximized.  I find

this to be much faster when

viewing images or using any

of the other functions of the

program.

To access this box, go to

Edit>Preferences and click

on the “General” tab (if it is

not already selected).  Then

check the box near the bottom.  Of course, you can always uncheck

the box later if you find you prefer a small window more often that a

maximized one.

2. Two-stage cropping - define crop rectangle size, and then

its position.  With this option, you can set the size of a crop first,

then fine-tune the position of the crop rectangle to make the best

image.  Conversely, if you feel that your cropping is the way you

want it all the time, and you are bothered by the fact that you have to

click again to get the crop to "take", you can uncheck that option.

This checkbox can be found in the Preferences under the “Crop”

tab.

by Dennis Green



       SPM Quick Tips    2018   |     |     SPM Quick Tips 2018 1716

Of course, the “floating window” can also be used as a creative

effect.  In the image below, the middle seagull is actually in front of

the surface of the paper, but the floating window boarder puts it at

the same location as the gray border (view this image with anaglyph

glasses to see the effect).

The above image shows the result of applying a single floating

window.  You can, if you wish, apply multiple windows as shown

below.

Save the floating window image with a new name.        [    ][    ]

SPM Tip: Create a Floating Window
 by Dennis Green

Some images may be plagued with “ghosting” (seeing a faint

doubled image on part of your subject).  This is most often seen in

high-contrast subjects - having a bright object in front of a dark

background - or in anaglyph images.  The most common way to

reduce “ghosting” is to position that object “at the window”, i.e. to

exactly overlap that object.

When you do that, you are usually bringing the scene forward in the

stereo window (see “Setting the Stereo Window” in SPM Quick

Tips Volume II in the club website “How to...” page).  This can result

in parts of the image on the side being in front of the window and

colliding with the border, which causes a window violation.  SPM’s

Floating Window option allows you to float a bordered window in

front of the viewing surface in order to avoid the violation.

First, go to Edit->Floating window and

choose “Floating window setting”.

You can specify the width of the

boarder of your floating window either

in a set number of pixels or as a

percentage of the image width.  You

can also specify the colors for each

border, and whether to have rounded

corners for the middle border.

Once you set your default values, you

can still adjust the window’s location

by using the left arrow key to move the

window forward, or the right arrow key

to move it backwards.

As with all SPM changes, if you do not like the result, you can undo

the change (Edit->undo or press the “Z” key) and change your

settings until you get one that you like.
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SPM Tip - Fuzzy Border / Sphere
 by Dennis Green

There are a couple of ways to play with the way you format your

images with SPM that can be creative tools,  One is adding a fuzzy

border.  While this can be used to fix a minor window violation in

the same way as using a floating window (see the SPM Tip from

February), it can also be added just as a creative element.

To create the fuzzy border, open an image in SPM and then select

Edit->Add Fuzzy Border (or use Shift-B).

You will get a dialog box

similar to this one. You can

set the border width in

pixels, and the gradient in

percentage (0% is a hard

line, 100% is completely

fuzzy).  You can also choose

to have rounded corners, or

to have a color other than

black, which can be another

effect.

These settings will look

different depending on the

resolution of your image.  Larger images will require a greater

number of border pixels to get the same effect.  You can play with

these settings and try different variations.  If you don’t like the effect,

just Undo (hit the “Z” key) and try something else.

SPM Tip - Split/Create MPO File
 by Dennis Green

When you take a picture with a true stereo camera like the Fuji W3,

the image pair is saved in the .mpo format (multiple picture object).

This format saves two (or more) .jpg images in a single file, and it is

recognized by some 3D TVs as the format that identifies a 3D

image.  This turns on the TV’s 3D function automatically.

But you may want to send or print the individual Left or Right image

of a pair.  Conversely, you may have two individual images from a

twin camera rig or a cha-cha stereo image that you would like to

convert to the .mpo format to use with a TV or other device.  SPM

has the ability to split the .mpo file into two .jpg images or make

one MPO out of separate JPEG images.  To split an MPO:

1. Create a folder for the group of images (example “Parade”) and

in that folder create sub-folders for “MPO”, “Left” and “Right”.

2. Copy your MPO images into the “MPO” folder.

3. Start SPM and choose File->Create/Split MPO File...

4. Click the down arrow next to the “Look in” box and browse to the

“MPO” folder.

5. In “Files of type:”, click the down arrow and select “MPO Multi-

Picture Format”. The dialog box title will change to “Split MPO File

(MPO--->Jpeg)”.

6. Click on each “Output Folder” browse button and select the “Left”

and “Right” image folders.

7. Click on “Convert all files” to losslessly extract the images to the

left and right folders.

To create an MPO file, change the “Files of type” selection to either

“SBS (parallel)”, “SBS (cross)” or “L/R JPEG Files”, depending on

the format you have. The dialog box title will change to “Create

MPO File (Jpeg--->MPO)”.  Select your output folder, then click on

“Convert all files”, and in seconds you will have MPOs in your folder.

As always, it is best to work with copies of your files, leaving the

originals in a safe place.       [    ][    ]
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SPM Tip: Multiple Images

StereoPhoto Maker is a great tool for aligning a pair of images (see

“Auto-Alignment” in SPM Quick Tips Volume II on our website).

But what if you need to align more than two images?  Common

types of multi-image formats would be lenticular images (you can

make a lenticular print from two images, but they are much better

when there are many in-between views are provided), bullet-time

movie sequences, or object-rotation movies of large subjects. SPM

can do the job!  This is done in two stages. The first is Auto rotation

adjustment (One by one) followed by X/Y adjustment & Cropping.

Here are the steps:

1. Capture the images: The types of images above are actually

made with a sequence of 2D images.  When capturing the images,

be careful that the change in viewpoint is not too large from one

image to the next, as this makes accurate alignment difficult.

If you have taken a sufficiently large number of images, such that

each adjacent pair can be viewed in stereo, then you can create a

stereo movie from them, as well.

2. Auto rotation adjustment (One by one):

Select Menu->File->Multiple Images->Auto rotation adjustment

(One by one)...

Choose options (Output File Type, etc...).

Enter Output folder name (if it does not exist, SPM can create it).

by Dennis Green

Another easy to create effect is one we have seen used for some of

the recent DISE winners - that is projecting an image onto a sphere.

This effect works best with an image whose main point of interest is

at or very near the center of the image.

This is perhaps the easiest effect to achieve, as there are not any

options when using it.  Just open your image and select the menu

item Edit->Spheric Deformation (or use the keys Ctrl + U), and your

image will instantly be transformed. It either works, or it doesn’t.

You could try this command on a whole folder of images, and only

save those that work for you.  I like to think of this modification as

taking an object and encasing it in a glass ornament.

Don’t be afraid to experiment with these tools, but always do your

experiments on copies of your images, keeping the originals in

another location.  And most important - have fun!     [    ][    ]
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SPM Quick Tip: Associate SPM with IE
By Dennis Green

SPM may be associated with Internet Explorer to

give you the option of right-clicking on an HTML

document's images and having the dropdown

option to 'Open with SPM'.

Why would you need this? It will allow you to view

internet images in formats other than side-by-side

(if you have a 3D monitor or want to view in anag-

lyph with red-cyan glasses, for example).

To activate this option in SPM, just go to the Edit

menu and select Preferences-> IE Context Menu.

In this box, click on ‘Enable IE

Context Menu’ and select

whether you want a temporary

version of the image (which

will be saved in a ‘Temp’ folder

and later deleted), or specify a

folder for viewing later. This

will allow you to view multiple

images without opening SPM

for each image you view.

You can set the input and

viewing options by going to

Edit->Preferences->Launch.

In addition to the input and

viewing options, you can

specify that the images are

displayed in full screen mode,

or swap the left and right

images if need be.    [    ][    ]
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Press 'Auto alignment

Setting', then check

'Better precision (Slow)'

option.  If your image

sequence is captured

by moving from left to

right, then input-image

arrangement is parallel.

Then press 'Convert all

files' from the previous

dialog box (which will appear when you press OK on this one).

3. Select X/Y adjustment & Cropping (from first dialog box).

Input the Output folder name as before.  Make sure that you enter a

different folder name than that used for your source or first-stage

processed images to avoid overwriting them!

4. X/Y Adjustment:  Select input files which were adjusted in the

above process, then push the convert button.

Select a prominent, easily-recognized feature that is visible in all

images to use as the common corresponding point.

Push 'Set Point' button, then click the mouse button on the common

corresponding points when they are exactly under the cross-hair.

After clicking the mouse button, SPM changes to the next image, so

continue to specify common corresponding points for all images.

5. Cropping: Push the 'Mask' button to create the masks that

define the area common to each

image.  Push the 'Crop' button and

specify the cropping area with

mouse-drag.  If you make a mis-

take, just repeat the operation.

The crop area will be outlined in

red.  Then, push 'OK' to save the

resulting images.  That’s it!

Full detailed instructions can be

found on the help website:

http://stereo.jpn.org/eng/stphmkr/help/index.htm.  Select the first link

in the ‘Other Functions’ area.        [    ][    ]


